Overview
This article presents how you can check and update your payment and billing details, such as credit card number, on the CMS platform.
Diagnosis
You may need to check or even edit your billing information if you have changed your credit card number but also check your subscription plan (status and coming billing cycle).
Prerequisites
- Active credit card
Solution
To update billing information through the CMS portal, follow the steps below:
1. Navigate to BiznessApp Dashboard > Click the drop-down menu (down arrow) on the top right-hand side of the page > Select the option Billing Details.
2. On the left-hand side of the new page that will appear, you will find information about your Subscription Status.
3. On the right-hand side, the Payment and Billing Information will appear. Under "Payment & Billing Information" select "Update payment & billing Information".
4. Once you update the payment & billing information, agree to the Privacy Policy, Terms of Service and Subscription Terms.
5. Click on the Update button at the bottom of the page
Important: For security reasons, you should change your billing details yourself and not share sensitive information like credit card numbers and CVV numbers with our support agents.
Testing
You will have updated your billing information details and your new card details will be registered in the system. You will receive the following message:
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